PSLS.net Home

Sony Confirms PS4 Headset Compatability, Many Will Require a Future Firmware Update

October 10, 2013 Written by Jason Dunning

PULSE-Review-1

After Shuhei Yoshida confirmed that the Pulse Elite Gaming headset would “eventually” work with the PS4, and Astro Gaming stating that their headsets will work with the PS4 following a future system update, new information comes from Sony about headset compatibility (via Game Informer):

  • When it comes to the Pulse/Pulse Elite headset from Sony, they confirmed that you will have to wait for a future PS4 system update to use them.
  • Any other headset that relies on bluetooth for chat won’t work at all.
  • A headset that relies on USB for chat will eventually work following a future system update.
  • Any headset that relies on digital optical for game audio will work, but you won’t be able to chat yet.

These restrictions are definitely a little confusing, but don’t forget that the PS4 comes with the below mono headset at launch, and the DualShock 4 has a headphone jack, allowing the use of other headphones for certain audio, though “it depends” for the mic part:

ps4headsetearset

What do you think of all these headset restrictions? Let us know in the comments below.

Essential Reading: